paste your error message

Are you seeing an error message like this when running a Perl script?

This means you are missing a Perl module, in this specific case LWP::UserAgent.
(The module name is the first file name without the .pm and with :: instead of /)

How to install a Perl module from CPAN

Install LWP::UserAgent on your system using cpanminus, a zero configuration CPAN client:

curl -L | sudo perl - App::cpanminus↳ Downloads and installs cpanminus as root (with sudo)
sudo cpanm LWP::UserAgent↳ Uses cpanminus to install LWP::UserAgent as root (with sudo)

Or, if you don’t have root access, you can install to ~/perl5 instead:

curl -L | perl - -l ~/perl5 local::lib App::cpanminus↳ Downloads and installs local::lib and cpanminus to ~/perl5
echo 'eval $(perl -I ~/perl5/lib/perl5 -Mlocal::lib)' >> ~/.bashrc↳ Writes environment variables with local::lib to ~/.bashrc
eval $(perl -I ~/perl5/lib/perl5 -Mlocal::lib)↳ Sets up environment variables with local::lib in this session
cpanm LWP::UserAgent↳ Installs LWP::UserAgent to ~/perl5 (due to environment variables)

It doesn’t work?

1) cpanm says: "! Can't configure the distribution. You probably need to have 'make'. See /home/derp/.cpanm/build.log for details."

Apparently, your system does not have the make command, which you need to install Perl modules.

On Debian, use:
sudo apt-get install build-essential